Overview:
TPControl token values are paired with a 'TPC Device ID' at the time of registration. TPC Device IDs are used in the identification of devices and matching registration information for tokens. Previously we used hardware identifiers such as UDIDs for iOS and MAC addresses for Android OS devices. Since iOS7 and Android OS6 (Windows has always used TPC device ID), TPControl has switched to using the 'TPC Device ID' for pairing and identification, and while this is typically reliable for device registration validation, there are certain situations that can lead to the TPC device ID being deleted or changed causing the device to report its license as invalid.
Causes:
There are several scenarios which can lead to the TPC device ID being changed or deleted from the device:
- Operating System updates
- Deleting and reinstalling TPControl
- Resetting the device to factory default, and not restoring from a backup of the device that contained TPControl.
- Using different user profiles on the device that TPControl was not installed and registered with.
- Installing custom or 'jailbroken' operating systems.
- Incorrect entry of token ID, email or pin when registering device.
- TPControl for iOS version installed is 2.6.4.0 or below
- Windows PC's with multiple network adapters enabled. Typically VM network adapters.
- Custom built Android devices that do not have unique MAC addresses or other device identifiers.
Solutions:
iOS Specific:
- Update to the latest version of TPControl.
In some cases, even though the Invalid License warning appears, a token value may actually be available on the device. Check by reviewing:
- iOS: ‘Settings -> TPControl -> Version: Token'
- Android: ‘TPControl -> MENU/Settings -> Version: Token'
- Windows 8/RT/10: ‘TPControl -> Settings -> Advanced -> Version: Token'
Armed with the token value, to re-register the device first try the on-device 'Token Registration' option, which is available within Settings for TPControl to get affected devices re-registered. Only if that method fails will you need to resort to using the 'Deauthorize by Request' option available in 'TPCloud > Tokens > (token) > Deauthorize', or by contacting support for assistance with manual deauthorization.
Warning!
It is the responsibility of the AMX integrator and/or end-user to ensure that they retain a reference to any TPControl license Token value that has been purchased.
Touch Panel Control provides online management of all purchased Tokens via TPCloud, but may not be able to positively identify Token ownership in cases where integrators and/or end-users do not know their TPControl Token value.
If the token ID cannot be located, we will endeavor to assist in identifying tokens if and where possible. We will require any information available for the install, including;
- Original installer name and email.
- Site name or customer/business name
- When the device was initially registered.
- If purchased direct from the TPC store, invoice record.
Any other information pertaining to the site will also assist in identifying a lost token ID will also be helpful.